¡Te damos la bienvenida al nuevo sysarmy --help! Para recuperar tu usuario pedí un password reset.

Windows/Office - Problemas con validación de credenciales en cuarentena

editado 30 de August en General

Buen dia!

Quisiera hacerles una consulta acerca de un inconveniente con el pack de Office que manejamos en la empresa donde trabajo.


Contexto:

2019 - la empresa implementó un proyecto para migrar todas las maquinas de W7 a W10. Aunque con alguna que otra turbulencia, se logró migrar la gran mayoria de las maquians

2020 - Entramos en cuarentena y, por ende, hace casi 6 meses que las maquinas (desktop y laptops) corp no se comunican a la red para validar las credenciales, en especial de los productos Office. Hasta hace 1 mes aprox, eso no era un problema ya que los programas sincronizaban la info bien pero tanto Outlook como Onedrive empezaron a joder un poco con las credenciales.


Datos:

  • total de 800 users LATAM; la mayoria trabajando con desktops de la empresa o personales
  • Menos de la mitad esta usando notebooks
  • La mayor parte de las maquinas que no migraron son laptops Dell Latitude 7490
  • Todas con W10
  • Usamos O365
  • Teams, Skype, Word, Excel y Powerpoint funcionan bien; Outlook y OneDrive no permitian el sign in
  • Aparentemente, solo afecta a notebooks (9 o 10 por el momento). No tuvimos casos de desktops con este issue.
  • La licencia de Windows vence en 15 dias, aprox - no estoy seguro de que esté relacionado
  • Azure AD, pero con algunas cosas hibridas (Exchange, especialmente)


Troubleshooting:

  • Reiniciar PC (doh!) - algo simple pero he visto maquinas con uptime de 42 dias
  • reinstalar pack de Office
  • crear nuevo perfil de Outlook
  • forcé las actualizaciones online de Windows pero no dió resultado
  • intenté forzar la sincronización de la licencia (CMD -> slmgr /ato) pero se muestra un error de que no la encuentra o no se puede comunicar...enfin, falla


El problema:

  • Según el técnico del equipo que responsable por ese proyecto, el problema es que por alguna razón misteriosa, el TPM no se encuentra activado en la BIOS pero si se ve en Windows (como si hubiera guardado alguna config/info vieja; no sabria explicar bien). Sin ese chip habilitado desde la BIOS, W10 o los productos de Office no podrían sincronizar la info, aunque el usuário la ingrese manualmente.
  • Ese mismo técnico sugerió que el chip puede estar roto y sugerió entrar en contacto con Dell para que un tecnico lo revise personalmente. Dado el contexto actual, es una opción complicada pero se podría intentar


Workaround:

  • Encontré en un foro de Microsoft que este problemes relativamente comun y, agregando una DWORD "EnableADAL" o algo similar (valor 1 para Outlook; 2 para Onedrive), se permitia el login. Una vez creada la clave y reinciado el programa, voilá, las apps sincronizaban normalmente luego de ingresar las credenciales

Mas allá del workaround, la idea es encontrar la raíz del problema y solucionarlo (o derivar a quien corresponda, que es lo más probable) para que se pueda replicar para todas las demás maquinas.


Tienen idea de qué podría ser o como confirmar si realmente es el chip TPM? Soy nivel 1 pero me tiro a la pileta sin miedo.


Saludos y gracias de antemano!

Etiquetado:
Accede o Regístrate para comentar.